We're back! Don't sneeze.

Submitted by C B Wright on

My regularly scheduled irregular schedule was interrupted yesterday when I tried to be a responsible site owner and keep my site up to date. The best way to do that, obviously, was to very irresponsibly try to upgrade the entire server to Ubuntu 14.04 LTS. This mostly went well, except for the parts that didn't. Specifically: upgrading Apache 2.2 to Apache 2.4 is apparently a Very Bad Idea unless you know what you're doing.

... I didn't know what I was doing.

So I spent most of yesterday evening banging my head against my desk. Today, wedged in between doing real (read: paying) work, I started to make progress. I finally decided to devote two hours to see if I could get everything up and running again, and I think I can tentatively say that I have.

Tentatively.

Very tentatively.

At this point I don't think I'm going to have to go with my worst-case scenario, which was "wipe the server clean, rebuild it all from scratch, restore database and site from backups." This means I suddenly have a weekend again, which is nice. I might be able to use it for writing, or something like that.

Anyway. Here's hoping. Let me know if you see anything rattling where it shouldn't.

Comments

Comments are active for 30 days after publication. If you wish to comment after 30 days please use the Forums.

Well, for a while I was

Well, for a while I was seeing something rattling. It was something about a SSL error saying it could not establish a secure connection. (It seems to be gone at the moment, or else I could not post this.)

I wonder if it was a conflict

I wonder if it was a conflict in the cache from a previous visit? I had to make changes to the configuration files apache uses and the virtual environment it was running in before is a bit different, so I guess that could be it.

I'm never sure with SSL, though.

--
Writer, former musician, occasional cartoonist, and noted authority on his own opinions.

Not sure of my facts here,

Not sure of my facts here, but I am pretty sure that there were 8 or 9 comments on the "An update on Curveball Issue 18" before the crash.

I don't think so... I'm

I don't think so... I'm working off the same database (I didn't have to restore it).

--
Writer, former musician, occasional cartoonist, and noted authority on his own opinions.

upgrading Apache 2.2 to

upgrading Apache 2.2 to Apache 2.4 is apparently a Very Bad Idea unless you know what you're doing

That one had me literally laughing out loud.

The alternate plan would have been to stay on 12.04 until 16.04 hits...

Well, in unexpected but

Well, in unexpected but welcome news, I can see the site again! (I'm thinking it was something to do with the proxy where I usually read your page.)

Can you give me a little more

Can you give me a little more information on this proxy? I'd like to try to figure out if the issue had to do with an external service that I can't do anything about, or if there's something I need to change on my site to allow external services to read my site correctly.

--
Writer, former musician, occasional cartoonist, and noted authority on his own opinions.